Problème email ISPconfig 3 ovh

Avant d’entrer dans le vif du sujet, nous allons faire un petit encart sur des problèmes que peuvent rencontrer les webmasters de boutiques en ligne.
Suivant la solution web que vous utilisez ainsi que du succès de votre site, vous serez peut être amené à passer votre ou vos boutiques sur un serveur dédié. Au passage, certains verront que le travail de webmaster ne vous a pas forcément préparer à administrer un serveur dédié.

Le problème d’aujourd’hui concerne les possesseurs de serveurs dédiés chez OVH avec certaines distributions prêtes à l’emploi. Notre article est basé sur la distribution Debian + ISPconfig 3.

Depuis quelques jours, le 16 avril précisément, vous avez peut être été victime d’un problème de réception d’email : aucun message d’erreur lors de la réception par un client POP mais plus aucun email entrant du tout. Nous allons voir dans cet article d’où vient ce problème d’email et comment y remédier facilement.

En vous rendant sur votre administration ISPconfig 3, vous pouvez voir 1 ou 2 warnings dans la section Monitor. En cliquant sur More information…, on voit Your Virus-protection is OUTDATED!. Puis encore un clic sur [More…] et on trouve les informations sur Clamav du type :

WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.94.2 Recommended version: 0.96

Continuons nos investigations et allons voir sur le serveur les fichiers /var/log/mail.err et /var/log/mail.info. Dedans on trouve une confirmation de notre problème :

(!!)TROUBLE in check_mail: virus_scan FAILED: virus_scan: ALL VIRUS SCANNERS FAILED: ClamAV-clamd av-scanner FAILED
**************************************************\nLibClamAV Warning: *** This version of the ClamAV engine is outdated.
(!!)…atabase at line 742\nLibClamAV Error: Can’t load daily.ndb

Il s’agit donc d’un problème avec une version trop ancienne de ClamAV. Les distributions d’OVH concernées sont en version 0.94.2.
Pour faire court, ClamAV avait annoncé il y a bien longtemps, (le 5 Octobre 2009) que le 15 avril 2010, grâce à une signature spéciale, les versions de ClamAV inférieures à la 0.95 seraient simplement désactivées. Selon ClamAV, c’est pour parer à un bug sur les mises à jour, et selon OVH ce blocage a été entrepris afin de parer à une grosse faille de sécurité…
Quoi qu’il en soit, ceci s’est soldé par une panne d’email de tous les serveurs incriminés, le 16 Avril 2010 à 2H du matin !

OVH a sorti un patch pour sa distribution « Release 2 ».

Pour ISPconfig 3, c’est un petit peu plus compliqué mais il n’y a rien d’insurmontable. Munissez vous de votre connexion SSH et laissez vous guider !

Premièrement, il vous faut modifier votre fichier etc/apt/sources.list afin d’inclure ces dépots :

deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free
deb-src http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free

Ensuite il suffit de lancer :

apt-get update

Puis

apt-get upgrade clamav

Dans certains cas, cela devrait suffire, mais en étant franc, nous nous sommes heurté à des problèmes avec cette manipulation sur un second serveur.
Il nous a fallu désinstaller ClamAV :

apt-get remove clamav

Puis le réinstaller :

apt-get install clamav

Autant en profiter pour rebooter le serveur :

/sbin/reboot

(Sur un 3ème serveur, en plus d’avoir du désinstaller/réinstaller ClamAV, après le reboot ISPconfig avait perdu les pédales en ne voyait aucun service en route alors qu’ils l’étaient. Au lieu de redemarrer les services un à un, nous avons simplement rebooté une seconde fois et la situation est revenue à la normale…)

Maintenant, en allant sur d’ISPconfig -> onglet Monitor -> More information… -> Your Virus-protection is OUTDATED! [More…]. Nous devons voir :

WARNING: Local version: 0.95.3 Recommended version: 0.96

Nous sommes bien passé en version 0.95.3 et vos emails vont à nouveau fonctionner et être filtrés 😉

Bonne continuation à tous et à bientôt pour des articles sur le Dropshipping !

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *